Sustained High Database Load
Incident Report for FOSSA, Inc.
Resolved
We've resolved the incident on the backend and functionality has been restored. We will continue to monitor and make improvements in our response.
Posted Jul 13, 2023 - 11:27 PDT
Monitoring
We are out of maintenance mode and are now monitoring.
Posted Jul 13, 2023 - 11:14 PDT
Update
We are proceeding with a database restart, which will trigger a temporary maintenance mode across the platform.
Posted Jul 13, 2023 - 10:41 PDT
Update
We are continuing remediation efforts based on the previously likely identified cause.
Posted Jul 13, 2023 - 10:39 PDT
Update
We are continuing remediation efforts based on the previously likely identified cause.
Posted Jul 13, 2023 - 09:59 PDT
Identified
We believe to have identified a potential cause for the DB load and will be attempting a remediation.
Posted Jul 13, 2023 - 09:38 PDT
Update
We are continuing the investigation. Due to the database load affecting potentially other components, we are widening the scope of the outage to "partial outage" on all components interacting with the database
Posted Jul 13, 2023 - 09:28 PDT
Update
We are continuing to investigate this issue.
Posted Jul 13, 2023 - 09:11 PDT
Investigating
We are currently investigating high database load which is impacting UI performance.
Posted Jul 13, 2023 - 08:40 PDT
This incident affected: Web application (app.fossa.com, Issue scanning, Report generation, API, Third-party integrations), Source code analysis (Quick Import, CLI), and Component analysis (Licensing, Vulnerabilities, Quality).