Degraded System Performance - High CPU load

Incident Report for FOSSA, Inc.

Resolved

We have concluded that CPU loads are back to sustained, nominal levels. We are therefore considering this resolved at this time.
Posted May 21, 2025 - 09:15 PDT

Update

We are continuing to monitor the CPU load concerns and are incrementally testing permanent resolutions
Posted May 21, 2025 - 06:53 PDT

Update

We are continuing to monitor for any further issues.
Posted May 20, 2025 - 15:31 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2025 - 15:30 PDT

Update

We are continuing to investigate this issue.
Posted May 20, 2025 - 14:26 PDT

Update

We are continuing to investigate the cause of the CPU load.
Posted May 20, 2025 - 14:11 PDT

Update

We are continuing to investigate this issue.
Posted May 20, 2025 - 14:04 PDT

Update

We are continuing to investigate this issue.
Posted May 20, 2025 - 14:01 PDT

Investigating

We are currently investigating a high CPU load issue which is causing UI slowness and other core services slowness
Posted May 20, 2025 - 14:00 PDT
This incident affected: Web application (app.fossa.com, Issue scanning, Report generation, API, Third-party integrations), Source code analysis (Quick Import, CLI, Vendored Source Identification, Snippet Scanning), and Component analysis (Licensing, Vulnerabilities, Quality).